Slide thumbnail

اخبار > آسیب‌پذیری تزریق دستور Cisco IOS XE از طریق رابط وب



دو آسیب‌پذیری در رابط وب محصولات سیسکو وجود دارد که به مهاجمین امکان تزریق دستورات را می‌دهد. این دو نقص در محصولاتی وجود دارند که از سیستم‌عامل IOS XE استفاده می‌کنند.

آسیب‌پذیری CVE-2019-12651 در صورتی قابل سوء استفاده است که هکر احراز هویت شده، اما دارای سطح دسترسی پایین باشد. هکر می‌تواند با کمک این نقص دسترسی خود را به سطح 15 ارتقاء داده و دستورات IOS را روی تجهیز اجرا کند.

آسیب‌پذیری CVE-2019-12650 به مهاجم راه دور احراز هویت شده اجازه می‌دهد تا روی شِل لینوکس تجهیز، دستور دلخواه خود را در قالب کاربر root اجرا کند. برای این کار، مهاجم باید دارای دسترسی سطح بالا یعنی 15 باشد.

هر دو این نقص‌ها به علت پاکسازی (sanitization) نادرست ورودی اتفاق می‌افتند. مهاجم می‌تواند در برخی فرم‌های وب رشته‌های خاصی را وارد کند و با ثبت کردن فرم، آسیب‌پذیری را مورد سوء استفاده قرار دهد.


 

این آسیب‌پذیری‌ها تنها در صورتی موثر اند که سرور http فعال باشد. با استفاده از دستور زیر می‌توانید فعال بودن آن را بررسی کنید:

Router# show running-config | include ip http server|secure-server

اگر هر یک از عبارات زیر در خروجی ظاهر شوند، آسیب‌پذیری به تجهیز وارد است:

ip http server

ip http secure-server

اما اگر خروجی به شکل زیر باشد، آسیب‌پذیری وارد نیست:

ip http active-session-modules none

ip http secure-active-session-modules none

سیسکو برای این آسیب‌پذیری‌ها، به‌روزرسانی امنیتی منتشر کرده است. اما تا زمان نصب به‌روزرسانی‌ها می‌توانید سرور http را غیرفعال کنید. به این منظور، از دستورات زیر استفاده می‌شود:

no ip http server

no ip http secure-server

بسته به اینکه از http server استفاده می‌کنید یا http secure-server باید یک یا هر دو دستور فوق ا اجرا کنید. همچنین توصیه می‌شود دسترسی به رابط وب را تنها به کاربران مورد اعتماد محدود کنید.

 

 

منبع: سیسکو



          

  

گروه خبری: اخبار ورویدادها / تاریخ: سه شنبه ٩ مهر ١٣٩٨ /  ساعت: ٢٠:٠٤ تعداد نمایش: 44 /   کد خبر: ١٧٠١٥



نظرات بینندگان
این خبر فاقد نظر می باشد
نظر شما
نام :
ایمیل : 
*نظرات :
متن تصویر:
 





تقویم شمسی